Hey guys ! For those who are interested in playing Blade and Soul as their favourite
character I prepared some detailed instructions with the easiest methods possible to achieve it. Don't
worry if you are not a pro designer. This tutorial will show you step by step how to paint a whole
new character with just few drags of a mouse ! Some corrections and few hours of time will be
needed of course to get the result close to the one shown below. Because of quite a big number of
requests I decided to upload my work process instead of creating a different character for everybody
(just like the one here...). It took ages to make so I hope it will help all the BnS mod community to
Srow.
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. FAQ ABOUT MODDING

PREPARATIONS: DOWNLOAD AND INSTALL — BnS Mod Tool, Umodel, UPK Manager,
Hex Workshow, Blender or Maya + PSK. plugin, Gimp or Photoshop (google it and make it work)

1. SEARCHING FOR DESIRED CHARACTER

If you already decided that you want to play Blade and Soul as your favourite character, then
you need to find some pictures from the internet with good quality and resolution. I reccomend to
get references which are neccesary to paint your character way faster. I always use 2 orthogonal
images of front and back side of the body. Pictures shown below can be easily painted on 3d model
with ortogonal view enabled. You will see very soon how fast and easy it is.



2. FINDING APPROPRIATE 3D MODEL

Second step requires decent knowledge about the items from the game. We need to find an
outfit with the model similar to our character references. The best way to know which items to
choose is to open some upk. viewer like BnS Mod Tool by Jonathan. Just set the 'Race” and ,,Type
of item” in the program, then check all the available models and compare them with your character.
It's important to look for potencial cuts in the model. What I mean by that is to see how many
»layers” of polygons the model has. For example the one shown below which I used for the Saber
from Fate Zero is full of stripes and baggy parts of the outfit. Those elements are what I call ,,layer
2”. Layer 2 can be easily modified to create different shapes. Layer 1 is the main body. If you cut
layer 1 in 3D software, you will have a holes in your character. It's mainly the whole body skin and
some parts of the clothing. The model is like a blown easter egg. You don't want to see what's
inside. Only decoration matters. (Keep note: Outfits can't be combined with other outfits set as e.g
head item. The game will crush a lot.)

If you intend to create realistic face, standard character customization fails no matter how
hard you try. For this issue the best way is to find face mask similar to the one is the pictures.

The last thing is a weapon. Look for the icons with special effects to get nicer look. It's not
easy to find a model matching desired look but all the special effects kind of compensate it.
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3. GETTING EDITABLE FILES

After chosing the items it's time to make them editable in 2D and 3D software. Copy the
numbers of every item you consider worth remaking from BnS Mod Tool or any other upk. viewer.
Use any text editor to save the upk. numbers and make some adnotations describing the items:

"skeleton": "00020504",

"texture": "00020502",

"material": "00020503",

"collMaterial": "00020503",

"001": "0011",

"core": "040080 JinF",

"code": "040080",

"race": "JinF",

"pic": "Attach 040080 JinM_coll.png" Geisha Mask



Open Umodel and wait for it to load all the upk. game files (3-10 min. of empty black
console sometimes...) Now when the files are loaded use the ,,filter” to find your files. You need
»skeleton” and ,texture”. According to numbers typed here, the files for Geisha Mask we need are
00020504 and 00020502. Copy+Paste them in the filter. The file you need will pop up in the table.
Select it and click ,,export”. Now you will have the folder named ,,UmodelExport” with the files
you have just exported. It should be in the program folder or \BnS\contents\bns . The software
converted ,,texture” to tga. format and ,,skeleton” to psk. format from Unreal Development Kit
(upk., udk.) files. Now we can close Umodel but don't be hasty. Remember it takes ages to load it.
Make sure you have all the wanted files exported. Save the numbers obtained from BnS Mod tool.
We will need it later.

& Choose a package to open x
[] Aat view Fitter: 00020504
=
4 Game Package name Skel Stat Anim  Tex Size. Kb
v | CookedPC 00020504 upk a7
mod
Hint: you may open this dialog at any time by pressing "0" Tools v Open |+ Cancel

4. IMPORTING AND EDITING

This is easily the most time consuming and chalengable part of the tutorial. We will start
with opening 3D software with installed psk. plugin. In my case, it going to be free software called
Blender. I can't teach you how to use it at full scale with just one simple tutorial but I will use only
few simple techniques to create the whole character. Hopefully it's going to be easy for you to copy
all the steps without any knowledge about 3D design.

I used very limited ammount of skills needed to learn. I followed my steps to check if I
didn't make any mistakes while writeing the instructions. Just follow the red circles and describtions
to learn everything you need to create good looking character.
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7. Now when the import part is
ready, navigate the scene with:

a)Hold MMB + drag = rotate
view

b)Shift + hold MMB + drag =
move view frm side to side
c)Scrool down/up = zoom out/in
d)Num 5 - ortogonal/perspective
e)Num 1/Shift Num 1 - side view

f)Num 3/Shift Num3 - front/back

Just practise this moves a little

bit untill you feel comfortable.
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10. Change "3D view" to "Texture View" :

) 7 then click "open" icon and select
[t | ) imported texture.
Croneme ] ;’ 11. Click "Image" > "Save as Image" >

/| {i Name it as your character

w 12. Now when the texture is saved and

e () ready to paint you can play around with

T g the model. Navigate around the model to

4 see which parts need to be cut for your
character to be more alike using chosen
outfit. | marked the parts | want to cut
with yellow lines. Look at your references.
13. Select/deselect the polygons - RMB/

3

L

Shift + RMB
Select from polygon to polygon-Ctrl+RMB epet

o Ve oS 0E Select multiple polygons one by one - o
Shift + RMB unselected polygon
Select many polygons one by one - Ctrl + e
Shift + RMB
Separate polys from mesh P>"Selection" Detnit

. Unselect/Select All - A

‘¢ To join them again > change to Object
=8 Mode>RMB cut parts > Shift+RMB on

@) DN G ) 5] @ view ¢ = [ o+ @+ ¢ e uniform > Ctrl + ) > change to Edit Mode

Before we go to cutting

and texture painting, o = \@\
take a look on the o ¥ S
stages needed to create ! v ) . /.’hf

a whole thing. Cut parts N
are marked with green \A; LONVAS

Pl

V4

5
color and some of them .
are hidden to have a e g ‘ ‘ ~ : l ‘ >
good view at 0 / \\\ / \\\
character's body. Look ‘ [ ‘ ‘ a fr A

how many haircuts and ’ ‘ ‘ \ " “

faces you can make

with masks like this
| | | |
h R

one.

1]

&)

v A
Ta

N3
A/
S L

A

ta
3

| B
i
[ &
D8




14 .Using the keyboard
shortcuts | gave you in
the previous image,
select the polygons and
click "P" to sepate them
from mesh.
15.Click "+" icon > Cllick
"eye icon" to hide
separated parts
(Do it in Object mode)
16. Save your progress.
Left, upper corner > File
> Save as. Keep note:
Saving the scene will
NOT save the painting
progress ! Textures are

> loaded from external
source. To save painting
progress you need o >
"Save as'image" like we ‘
did before [
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Now | will show you how
easy texture painting is.
17. Change to Texture Paint N
and Texture

18. Click the "texture" icon
and follow the arrows to
import your reference image
19. Tools >set "brush
mappoing" to stencil > set
"Image Aspect">move
mouse cursor to scene

20. Clink Num5 and other
Num numbers (shown
before) to set orthogonal
front view of the character.
In the "tools" you have also
paint radius and imput
settings to play around with
different type of painting

21. Set the position of the
image with the model by
draging the image with Hold
RMB and paint with LMB on
the image as if it was tracing
paper. Use navigation to set
the view.

22. Save painting progress
Image > Save as image

. e 23.Combining the paintings from
- ) all applied reference pictures
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"smearing". You can change the
brush tool from Texture Paint to
Smearing. In order to make
textures look united just smear
from left to right untill they blend
like gradient ramp colors.

24. Make final touches with
cutting and texture painting as
much as possible. Use 2D
program to make some
corrections of quality and colors.

This part may seem like a
milestone compared to previous
image but It won't be useful on
basis of merit if | show every
detail | made using the same
techniques. Making heads and
Folowia?002 weapons is exactly the same.
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This is how the final g
texture for original Saber's 3 i P
outfit really look like. And (e o o 53003 ok

by that | mean it's exactly 7
like this in the game. With
all the green parts replaced
by "Alfa texture". It makes
the skeletal mesh invisible
and it's not affected by
lighting, shadows and
supporting UV maps. We
didn't do anything with 3D
model. It was just needed
to see the whole picture of
the character based on
existing BnS model.

25. Now you just need to
do the same thing and join
all cut parts into one object
by Ctrl + J. Then take the
biggest brush there is and
use white imported texture
with color set on green to
make every poly the same.
When it's done, Image >
Save as image
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WE ARE DONE WITH 3D !




5. QUICK UV MAPPING

Compared to previous part, this one is super fast. We just need to open our custom diffuse
texture and make few changes to create a set of textures interacting with the game's graphic engine.
There are 4 main types of textures:

- diffuse map (standard texture with painted details and colors)

- normal map (bump effect, faking 3D shapes by reflecting the lighting on certain parts of the
diffuse texture)

- specular map (also known as reflection map, bright parts of the texture reflect more lighting)
- emission map (texture create it's own light source, bright parts of the texture produce stronger
emission)

There are other UV maps but those are used to create additional details. Specular maps have
usually green and blue colors used to define the power of reflection. However, many of them have
red parts used for character's skin to match the brightness and color of your BnS character. The only
part of the character's body which really have the skin color you have chosen in the starting
character customization is the face. For example, you can make an outfit with your specular map all
red and you will end up having super bright diffuse texture with a pale,white skin character and
super dark outfit with a dark skin character.

In order to create full basic set of UV textures open your diffuse map with Gimp, Photoshop
or any other 2D software then do the following:

1) Diffuse map (D)

Your custom texture has a lot of bright green parts used to determine which polygons should be cut.
Now you just need to ,,select by color” to select all the parts with this color. Then just delete it to
make it transparent. Make sure to clean up the texture from the green egdes if something didn't
select properly. Export texture with File > Export as > choose folder and format (tga. or png.)

2) Specular map (S)

Keep the diffuse map open. Now colorize the whole texture to be all green or light blue. Adjust
some contrast to make dark parts less reflective and light parts more reflective. Look at the image
below. You can see that the neck of outfit's specular map is red. It means the brightness will scale on
this part depending on the skin color your character has. Export as png. or tga.

3) Emission map (E) — You can make weapon emit any color you want. | painted it as yellow/purple
4) Normal map (N) — Put your diffuse map to any online converter. Customize your settings. Save.

Original outfit Remade outfit
¢

Original weapon




6. EXPORTING TEXTURES INTO THE GAME

The artistic part is finally over. It's time to rebuild the game files with our custom textures.
Open UPK manager. Let it load game files. Choose ,,Show files in type” > ,, Texture 2d”. Look for
the texture numbers in the filter on the lower window (from the text file you made based on BnS
Mod Tool ). Tick the upk. numbers and File > Export Selected Files. This process will create
custom folder for all your modded textures. You will see the files inside the folder with dds. format
(actual format of textures used in game). This folder can be saved anywhere on the disc.

Open the folder with all customized UV textures and compare them with the UPK manager's
export folder. See if you have the same number and type of textures as the original files. If you see
some additional files then create some empty, transparent textures to prevent the effect of original
textures on custom ones. You can't just delete them from the folder. Blade and soul will crush this
way or it will try to rebuild missing files.

Name your files the exact same way they are named in the UPK Manager's export folder
with dds. fomat.

Upload all your custom UV textures in any DDS. online converter. Make sure to set the
convertion settings supporting alfa chanels (DXT4 or DXTS5). Don't set it to RSGEBS etc. You will
end up getting all the item's cut parts white or black instead of transparent.

Copy your custom, converted dds. textures and paste them in the UPK Manager's export
folder. It will ask you if you want to replace few files. Make sure it's the number of textures inside
the folder you want to replace. Otherwise, you probably called them wrong or they aren't dds. files.

The last step is to create a new upk. file in BnS\contents\bns\CookedPC\mod. UPK Manager
will do it automatically if you go to ,,Rebuild” tab>search for bns/CookedPC>tick the upk. numbers
with replaced textures>"Rebuild”’(near Edit and Settings)>Rebuild Selected Exports

DONE ! Your custom character is already in the game ! Now it's only a matter of having replaced
items in the game or having any outfit, head and adorment to see if it worked as intended.

7. REPLACING CHOSEN ITEMS

For the last step I don't reccomend using BnS Mod Tool. It's very good at replacing outfits
but the adorments and head items are bugged very often. With older versions of the program you
can't replace weapons. We will use Hex Workshop in order to do it.

Go to ...\BnS\contents\bns\CookedPC and find the upk. files of original outfits you want to
replace with your custom textures. We already have them in the text file created at the beggining of
the tutorial. Copy upk. of ,,material” and ,,skeleton” to a new folder (call it HexEditMods or
something). Save this folder on the pulpit or other place. Use BnS Mod tool to search for numbers
of items you want to swap. For this tutorial we will use JIN FEMALE Training Weapon (Ivl 1),
Stalker's Head and Stalker's Outfit (1v1.6, first boss, items drop easily from Wheel of Fate).

For my outfit the numbers are — 00008206.upk (skeleton) and 00008205.upk (material)
For my head the numbers are - 00020504.upk (skeleton) and 00020503.upk (material)

Rename the ,,skeleton” and ,,material” with the name of upk. files belonging to items you have
already in game. (in this case — Stalker's Head and Stalker's Outfit)

For Geisha Mask (and now our character's head) to replace Stalker's Head I renamed:
skeleton: 00020504.upk to 00012184.upk
material: 00020503.upk. to 00019135.upk

For baggy, dark blue outfit to replace Stalker's Outfit I renamed:
skeleton: 00008206.upk to 00012176.upk
material: 00008205.upk. to 00012175.upk



Open copied skeleton upk. file from custom folder with RMB >, Hex edit with Hex Workshop”
Now do the following:
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Repeat those steps for every item you want. It doesn't matter if it's a weapon, head, outfit or
adorment. Don't try to replace Jin Female's items with other races's items. It will end up crushing
the game. Sometimes replacing col.mat with other col.mat doesn't work. You can try mat. instead.

Now just put hex edited items in ...\BnS\contents\LocaANCWEST\ENGLISH\CookedPC\mod
If you don't have ,,mod” folder just create it manually in this directory.

DON'T PUT IT IN ...\BnS\contents\bns\CookedPC
You should also check if your programs created ,,mod” folder in the right direction. If not, cut them
and paste them here ...\BnS\contents\LocaANCWEST\ENGLISH\CookedPC\mod

You may eventually end up getting error this way - ,,Unautorized folder was found in the CookedPC
folder”. It will still work fine but it's quite annoying to click ,,Ok” for every mod you put into the
game and... [ have plenty of them.

DONE ! The items are already in the game !

Note:

I tried to merge 2 outfits to make cutom 3D model and replace one of them for adorment. The
second outfit just didn't show up in the game yet it was crushing every 2 minutes. The reason it
happend is because the physics node from Unreal Engine is trying to simulate 2 items with mesh
collision set to ,,block all”. 2 spawned outfits in the same place are glitching with each other making
unwanted log outputs.



8. PLAYING!

Finally we ended the whole process of creating custom character. You can now launch Blade and
Soul and see if everything is working. It's also the best way to check if our character is made
properly. Sometimes there is too much bump, reflection, emission or the whole shaders are broken.
If you followed the tutorial without any mistakes it should look just fine. I gave you the exact files
used by my Saber from Fate Zero so you have a proof it can be done.

Have fun playing your custom characters ! :)
9. FAQ

This topic will be extended based on players's questions on
http://www.bladeandsouldojo.com/forums



